Imaios suggests that you upgrade to a recent browser and that you have the latest version of the free Adobe Flash Player installed in order to use the Imaios website as it is intended. You may experience problems without the most recent version of the Adobe Flash Player and a supported web browser. This TechNote covers system requirements for viewing content on and downloading content from the Imaios website.

 

Imaios Flash Player requirements

The Imaios website uses features in Adobe Flash Player version 9,0,115,0 and later. You cannot use anatomy modules in full screen mode without this player.
* Download it now free
Note: If you don't know which version of the Imaios Flash Player you have installed, you can test your player at the Adobe Flash Player Test page. If you have problems installing Flash Player, see the Flash Player Support Center.

 

Browser requirements

The Imaios website is supported by the latest versions of Microsoft Internet Explorer, Mozilla Firefox, Apple Safari, and Google Chrome. In order to experience the Imaios website fully, please upgrade to the latest version of one of the following browsers:

  • Microsoft Internet Explorer
  • Mozilla Firefox
  • Google Chrome
  • Apple Safari

 

Download requirements

Imaios recommends a DSL connection or faster for downloading anatomy modules, updates, or purchased products from Imaios.

 

Other requirements

JavaScript is used for key functionality on the Imaios website; thus, Javascript 1.2 or later must be enabled.

  • Enable JavaScript in your browser. Consult your browser's Help section for information on how to change this setting.
  • Upgrade your browser to a version that supports JavaScript 1.2 or higher (see browser list above).

 

Cookies must be enabled for certain portions of our site.

  • Make sure cookies are enabled. Consult your browser's Help section for information on how to change this setting.